const regex = /\|-+\|-+\|\s*(.*?)(?=\s*\|-+\|-+\|)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|-+\\|-+\\|\\s*(.*?)(?=\\s*\\|-+\\|-+\\|)', 'gs')
const str = `Donec sed odio dui. Donec id elit non mi porta gravida at eget metus.
|------|------|
|6 | TEXT |
|7 | TEXT |
|8,9 | TEXT |
|------|------|
Etiam porta sem malesuada magna mollis euismod. Praesent commodo cursus magna,
vel scelerisque nisl consectetur et. Nulla vitae elit libero, a pharetra `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}