import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|-+\\|-+\\|\\s*(.*?)(?=\\s*\\|-+\\|-+\\|)";
final String string = "Donec sed odio dui. Donec id elit non mi porta gravida at eget metus.\n"
+ "|------|------| \n"
+ "|6 | TEXT | \n"
+ "|7 | TEXT | \n"
+ "|8,9 | TEXT | \n"
+ "|------|------|\n"
+ "Etiam porta sem malesuada magna mollis euismod. Praesent commodo cursus magna,\n"
+ "vel scelerisque nisl consectetur et. Nulla vitae elit libero, a pharetra ";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}