$re = '/\|-+\|-+\|\s*(.*?)(?=\s*\|-+\|-+\|)/s';
$str = 'Donec sed odio dui. Donec id elit non mi porta gravida at eget metus.
|------|------|
|6 | TEXT |
|7 | TEXT |
|8,9 | TEXT |
|------|------|
Etiam porta sem malesuada magna mollis euismod. Praesent commodo cursus magna,
vel scelerisque nisl consectetur et. Nulla vitae elit libero, a pharetra ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);