# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/([bi])((?<=b)o|(?<=i)t)\s+([\w]+)/<$1>$3<\/$1>/g;t' <<< "Hello, isn't the /bo weather just /it beautiful. today!?"