use strict;
my $str = 'Hello, isn\'t the /bo weather just /it beautiful. today!?';
my $regex = qr/\/([bi])((?<=b)o|(?<=i)t)\s+([\w]+)/p;
my $subst = '<$1>$3</$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";