import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bwww\\.)https?:\\/\\/.*";
final String string = "http://www.example.org/\n"
+ "http://status.example.org/index.php?datacenter=1\n"
+ "https://status.example.org/index.php?datacenter=2\n"
+ "https://www.example.org/Insights\n"
+ "http://www.example.org/Careers/Job_Opportunities\n"
+ "http://www.example.org/Insights/Press-Releases";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}