$re = '/^(?!.*\bwww\.)https?:\/\/.*/m';
$str = 'http://www.example.org/
http://status.example.org/index.php?datacenter=1
https://status.example.org/index.php?datacenter=2
https://www.example.org/Insights
http://www.example.org/Careers/Job_Opportunities
http://www.example.org/Insights/Press-Releases';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;