# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\bwww\.)https?:\/\/.*"
test_str = ("http://www.example.org/\n"
"http://status.example.org/index.php?datacenter=1\n"
"https://status.example.org/index.php?datacenter=2\n"
"https://www.example.org/Insights\n"
"http://www.example.org/Careers/Job_Opportunities\n"
"http://www.example.org/Insights/Press-Releases")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.