const regex = /^(?!.*\bwww\.)https?:\/\/.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\bwww\\.)https?:\\\/\\\/.*', 'gm')
const str = `http://www.example.org/
http://status.example.org/index.php?datacenter=1
https://status.example.org/index.php?datacenter=2
https://www.example.org/Insights
http://www.example.org/Careers/Job_Opportunities
http://www.example.org/Insights/Press-Releases`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);