#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)#([[:xdigit:]]{3}){1,2}\b"
Local $sString = "#00" & @CRLF & _
"#049" & @CRLF & _
"#038f83" & @CRLF & _
"#3f9" & @CRLF & _
"#382794" & @CRLF & _
"#3937" & @CRLF & _
"#938f" & @CRLF & _
"#343,#523"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")