const regex = /#([[:xdigit:]]{3}){1,2}\b/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#([[:xdigit:]]{3}){1,2}\\b', 'img')
const str = `#00
#049
#038f83
#3f9
#382794
#3937
#938f
#343,#523`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}