package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)#([[:xdigit:]]{3}){1,2}\b`)
var str = `#00
#049
#038f83
#3f9
#382794
#3937
#938f
#343,#523`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}