import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#([[:xdigit:]]{3}){1,2}\\b";
final String string = "#00\n"
+ "#049\n"
+ "#038f83\n"
+ "#3f9\n"
+ "#382794\n"
+ "#3937\n"
+ "#938f\n"
+ "#343,#523";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}