// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)#([[:xdigit:]]{3}){1,2}\b").unwrap();
let string = "#00
#049
#038f83
#3f9
#382794
#3937
#938f
#343,#523";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}