$re = '/#([[:xdigit:]]{3}){1,2}\b/im';
$str = '#00
#049
#038f83
#3f9
#382794
#3937
#938f
#343,#523';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);