const regex = /<\s*img\s+src\s*=\s*\"(.*)\">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*img\\s+src\\s*=\\s*\\"(.*)\\">', 'g')
const str = `<img src = "file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg">
< img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg">
<img src="file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg">
<img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);