# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\s*img\s+src\s*=\s*\"(.*)\">"
test_str = ("<img src = \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg\">\n"
"< img src= \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg\">\n"
"<img src =\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg\">\n"
"<img src=\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg\">\n"
"<img src =\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg\">\n"
"<img src= \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.