re = /<\s*img\s+src\s*=\s*\"(.*)\">/
str = '<img src = "file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg">
< img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg">
<img src="file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg">
<img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result