// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<\s*img\s+src\s*=\s*\"(.*)\">"#).unwrap();
let string = "<img src = \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg\">
< img src= \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg\">
<img src =\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg\">
<img src=\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg\">
<img src =\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg\">
<img src= \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}