#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)"([^"]*)"|(?:\(|,)\s*([^"),]*)(?=,|\))"
Local $sString = "_("foo")" & @CRLF & _
"_n("bar", "baz", 42)" & @CRLF & _
"_n(domain, "bux", var)" & @CRLF & _
"_( "one (optional)" )" & @CRLF & _
"_( "No apples" )" & @CRLF & _
"_n("%1 apple", "%1 apples", apples)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")