$re = '/"([^"]*)"|(?:\(|,)\s*([^"),]*)(?=,|\))/i';
$str = '_("foo")
_n("bar", "baz", 42)
_n(domain, "bux", var)
_( "one (optional)" )
_( "No apples" )
_n("%1 apple", "%1 apples", apples)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);