using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""]*)""|(?:\(|,)\s*([^""),]*)(?=,|\))";
string input = @"_(""foo"")
_n(""bar"", ""baz"", 42)
_n(domain, ""bux"", var)
_( ""one (optional)"" )
_( ""No apples"" )
_n(""%1 apple"", ""%1 apples"", apples)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}