const regex = /"([^"]*)"|(?:\(|,)\s*([^"),]*)(?=,|\))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"([^"]*)"|(?:\\(|,)\\s*([^"),]*)(?=,|\\))', 'ig')
const str = `_("foo")
_n("bar", "baz", 42)
_n(domain, "bux", var)
_( "one (optional)" )
_( "No apples" )
_n("%1 apple", "%1 apples", apples)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}