import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]*)\"|(?:\\(|,)\\s*([^\"),]*)(?=,|\\))";
final String string = "_(\"foo\")\n"
+ "_n(\"bar\", \"baz\", 42)\n"
+ "_n(domain, \"bux\", var)\n"
+ "_( \"one (optional)\" )\n"
+ "_( \"No apples\" )\n"
+ "_n(\"%1 apple\", \"%1 apples\", apples)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}