re = /"([^"]*)"|(?:\(|,)\s*([^"),]*)(?=,|\))/i
str = '_("foo")
_n("bar", "baz", 42)
_n(domain, "bux", var)
_( "one (optional)" )
_( "No apples" )
_n("%1 apple", "%1 apples", apples)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end