# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[a-zA-Z0-9]+$/SG/mg;t' <<< "\"test1\"
#!@!2test
(test3)
@@test4---- ¿"