$re = '/^[a-zA-Z0-9]+$/m';
$str = '"test1"
#!@!2test
(test3)
@@test4---- ¿';
$subst = "SG";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;