import Foundation
let pattern = #"^[a-zA-Z0-9]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
"test1"
#!@!2test
(test3)
@@test4---- ¿
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"SG"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)