const regex = /^[a-zA-Z0-9]+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9]+$', 'mg')
const str = `"test1"
#!@!2test
(test3)
@@test4---- ¿`;
const subst = `SG`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);