#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[a-zA-Z0-9]+$"
Local $sString = ""test1"" & @CRLF & _
"#!@!2test" & @CRLF & _
"(test3)" & @CRLF & _
"@@test4---- ¿"
Local $sSubst = "SG"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)