use strict;
my $str = '"test1"
#!@!2test
(test3)
@@test4---- ¿';
my $regex = qr/^[a-zA-Z0-9]+$/mp;
my $subst = 'SG';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";