$re = '/<input.*orderId.*value="(.*)"/';
$str = '<input id="amount" type="hidden" value="105">
<input id="orderId" type="hidden" value="10000">
<input id="userId" type="hidden" value="200">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);