// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<input.*orderId.*value="(.*)""#).unwrap();
let string = "<input id=\"amount\" type=\"hidden\" value=\"105\">
<input id=\"orderId\" type=\"hidden\" value=\"10000\">
<input id=\"userId\" type=\"hidden\" value=\"200\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}