#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Cert>[\s\S]*?777[\s\S]*?<\/Cert>"
Local $sString = " <Cert>" & @CRLF & _
" <ObjectID></ObjectID>" & @CRLF & _
" <PersonnelID>290164</PersonnelID>" & @CRLF & _
" <CertType>CX777G9T2</CertType>" & @CRLF & _
" <CertNumber>000000</CertNumber>" & @CRLF & _
" <Default>false</Default>" & @CRLF & _
" </Cert>" & @CRLF & _
" <Cert>" & @CRLF & _
" <ObjectID></ObjectID>" & @CRLF & _
" <PersonnelID>290164</PersonnelID>" & @CRLF & _
" <CertType>CX7a7G9T2</CertType>" & @CRLF & _
" <CertNumber>000000</CertNumber>" & @CRLF & _
" <Default>false</Default>" & @CRLF & _
" </Cert>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")