import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Cert>[\\s\\S]*?777[\\s\\S]*?<\\/Cert>";
final String string = " <Cert>\n"
+ " <ObjectID></ObjectID>\n"
+ " <PersonnelID>290164</PersonnelID>\n"
+ " <CertType>CX777G9T2</CertType>\n"
+ " <CertNumber>000000</CertNumber>\n"
+ " <Default>false</Default>\n"
+ " </Cert>\n"
+ " <Cert>\n"
+ " <ObjectID></ObjectID>\n"
+ " <PersonnelID>290164</PersonnelID>\n"
+ " <CertType>CX7a7G9T2</CertType>\n"
+ " <CertNumber>000000</CertNumber>\n"
+ " <Default>false</Default>\n"
+ " </Cert>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}