use strict;
my $str = ' <Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX777G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>
<Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX7a7G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>';
my $regex = qr/<Cert>[\s\S]*?777[\s\S]*?<\/Cert>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}