re = /<Cert>[\s\S]*?777[\s\S]*?<\/Cert>/
str = ' <Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX777G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>
<Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX7a7G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end