// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<Cert>[\s\S]*?777[\s\S]*?<\/Cert>").unwrap();
let string = " <Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX777G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>
<Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX7a7G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}