using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Cert>[\s\S]*?777[\s\S]*?<\/Cert>";
string input = @" <Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX777G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>
<Cert>
<ObjectID></ObjectID>
<PersonnelID>290164</PersonnelID>
<CertType>CX7a7G9T2</CertType>
<CertNumber>000000</CertNumber>
<Default>false</Default>
</Cert>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}