#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(.*?)""
Local $sString = "[" & @CRLF & _
""GUID_ID_ONE"," & @CRLF & _
""2016-07-11T18:35:29Z"," & @CRLF & _
""email@address.com"," & @CRLF & _
""HASH_STRING"," & @CRLF & _
""GUID_KEY_TWO"," & @CRLF & _
""GUID_KEY_THREE"" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")