re = /"(.*?)"/
str = '[
"GUID_ID_ONE",
"2016-07-11T18:35:29Z",
"email@address.com",
"HASH_STRING",
"GUID_KEY_TWO",
"GUID_KEY_THREE"
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end