// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(.*?)""#).unwrap();
let string = "[
\"GUID_ID_ONE\",
\"2016-07-11T18:35:29Z\",
\"email@address.com\",
\"HASH_STRING\",
\"GUID_KEY_TWO\",
\"GUID_KEY_THREE\"
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}