import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(.*?)\"";
final String string = "[\n"
+ "\"GUID_ID_ONE\",\n"
+ "\"2016-07-11T18:35:29Z\",\n"
+ "\"email@address.com\",\n"
+ "\"HASH_STRING\",\n"
+ "\"GUID_KEY_TWO\",\n"
+ "\"GUID_KEY_THREE\"\n"
+ "]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}