using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(Cl(?:vland|and|ev))\b";
string substitution = @"Cleveland";
string input = @"City of Cleveland
City of Clvland
City of Boston
City New York
City of Clev
City of Miami
City of Cland
Cle Ci";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}