// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(Cl(?:vland|and|ev))\b").unwrap();
let string = "City of Cleveland
City of Clvland
City of Boston
City New York
City of Clev
City of Miami
City of Cland
Cle Ci";
let substitution = "Cleveland";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}