re = /\b(Cl(?:vland|and|ev))\b/m
str = 'City of Cleveland
City of Clvland
City of Boston
City New York
City of Clev
City of Miami
City of Cland
Cle Ci'
subst = 'Cleveland'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result