import re
regex = re.compile(r"\b(Cl(?:vland|and|ev))\b", flags=re.MULTILINE)
test_str = ("City of Cleveland\n"
"City of Clvland\n"
"City of Boston\n"
"City New York\n"
"City of Clev\n"
"City of Miami\n"
"City of Cland\n"
"Cle Ci")
subst = "Cleveland"
result = regex.sub(subst, test_str)
if result:
print(result)