$re = '/\b(Cl(?:vland|and|ev))\b/m';
$str = 'City of Cleveland
City of Clvland
City of Boston
City New York
City of Clev
City of Miami
City of Cland
Cle Ci';
$subst = "Cleveland";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;