use strict;
my $str = 'City of Cleveland
City of Clvland
City of Boston
City New York
City of Clev
City of Miami
City of Cland
Cle Ci';
my $regex = qr/\b(Cl(?:vland|and|ev))\b/mp;
my $subst = 'Cleveland';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";