import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"=.]+?)\"";
final String string = "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1\" >\n"
+ "<img src=\"picture.png\" alt=\"Picture\" width=\"800\" height=\"20\"/>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}